
Arnaud NAUWYNCK
arnaud.nauwynck@gmail.com 

Présentation Eclipse



Plan

● Introduction
– Présentation générale, Installation, Configuration
– Architecture en Plugins
– Workbench: Workspace, Perspectives, Views...

● Java Projects
– Créer et Configurer un Project Java
– Project Dependencies, Maven

● Using Eclipse JDT
– Browsing / Editing / Debugging



Audience - Prérequis

● Utilisation simple d'Eclipse (Browse)
– MOA, Notion de Java
– Utilisation d'un IDE

● Utilisation Avancée d'Eclipse (Dev, Debug...)
– MOE, Programmation Java
– Svn, Maven

● Développements de Plugin Eclipse
– Architecte, Ceinture noire Java



Introduction : Historique & Actualités

● Logiciel réalisé par IBM
– Expérience de Visual Age – Smalltalk
– Refonte technologique en Java
– Auteurs connus: Erich Gamma (Gof)...

● Maintenant Open-Source
– Plus gros dont de code!
– Fondation Eclipse.org
– Nombreux partenaires / contributeurs



Marché & Concurrents

● Marché? : Open-Source + Gratuit 
– ... MAIS modules payant

Ex: plugins pour IBM – Websphere
● Concurrents

– IntelliJ IDEA
– Borland JBuilder
– MS Visual Studio
– Xemacs
– Outils spécialés : UML, SGBD, XML...
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Eclipse Platform !=  Eclipse JDT

● Eclipse est une platforme d'intégration

● Eclipse n'est pas seulement “JDT” !!
● Exemple: “Eclipse CDT” pour C, C++ 

développé au même niveau que JDT
... pas d'API fermée, de restrictions

● JDT est “juste” une feature d'Eclipse !
... mais la partie la plus connue !!

● Eclipse.org assure la cohérence



Distributions / Contribs

● Customizer/Installer son Environnement
– Downloader + Rajouter des plugins

● Analogie système “Debian” : 
– choix d'une distribution type
– Ajout/suppression de packages standards
– Ajout/suppression de package contrib

● Pour système Eclipse :
– Distributions types: Eclipse SDK, Calisto, Europa, ...
– Packages standards : cf http://www.eclipse.org
– Package contrib: cf http://www.eclipse-plugins.org

http://www.eclipse.org/
http://www.eclipse-plugins.org/


Software Updates

● Gestion des features 
– Discover + Download + Install 
– Check Versions + check Dépendances

● => use Update Manager !



Update Manager

● Exemple : installation de “subclipse”(pour SVN)
● Update site = http://subclipse.tigris.org/update_1.2.x

http://subclipse.tigris.org/update_1.2.x


Eclipse RCP  ... Eclipse “minimaliste”

● Eclipse RCP  = Rich Client Platform
● SWT + ... = alternative de Swing !!
● Exemple: Eclipse SANS JDT !

SWT

JFace

Workbench

Eclipse RCP



Architecture d'Eclipse : Plugin

● Rappel ... règles OpenSource + d'intégration
– Fair-Play: “everyone play with the same rule”

IBM / Eclipse-Org / 3rd- parties / Contributors

● => Traduction en Règles de plugins
– Tout est fait en plugin
– Tout le monde peut écrire des plugins
– Les plugins peuvent tout faire
– Les plugins doivent être extensibles (par plugins)



Approche par Composants : Plugins

● Plugin = composant prêt à “plugger”

 = ensemble consistant/indépendant de classes
     (approche Orienté Composant)

 =    librairie (~ jar) 
+ descripteur (dépendances, version)
+ life-cycle (deploy/undeploy) 
+ intégration dans IDE

● Feature = groupe de plugins (ex: JDT)



Plugins – Core BootLoader

● Dépendance “import” entre Plugins
(idem librairie / package debian / projet maven...)

● Le plugin “core” / “bootloader” = server app
● Plugin = déployable ssi dépendances valides!

eclipse.core
(= AppServer)



Plugin Extension Points
● Les plugins sont isolés en “sandbox”

... Interaction uniquement par “extension-point”
● Point d'extension

= Interface = Registry d'objets gérés
● Extension

= Implémentation concrète, instance d'objet

Extension
= interface/registry

Extension-points
= object implementation



Exemple d'Extensions

● Dans Eclipse, presque tout est “extension”
● Tout ce qui est visible !
● Exemples

– Menu, Toolbar, Actions, Menus Contextuels
– Types de fichiers, Views, Editors
– Perspectives, Projets
– Builders, Launchers
– ...



Descripteur de Plugin
● Extensions déclarées en XML

– Intéraction plugins-platform lisibles
– Auto documentée, browsable, en xml

● Chargement lazy
– démarrage rapide / consommation mémoire



Structure d'un Plugin

● Plugin = jar ou répertoire
● Copié dans “eclipse/plugins/...”
● Contenu :

– Fichier “plugin.xml” 
– resources (jar, dll, etc..)
– I18n : properties



Installation d'Eclipse

● List de plugins en VRAC
● Déclarés éventuellement en groupe : “features”
● Externalisable via “Links”



Installation via Extension “Links”

● Méthode recommandée...
– Ne pas polluer l'installation par défaut
– Partage multi-version (eclipse 3.3, 3.4, ...)
– Shared eclipse / Custom links



Eclipse Workbench Concepts

● Malgré les 10000 contributions
– UI très homogène
– Ergonomie et Concepts cohérents
– ex: selection d'un objet 

=> ctx menu identique quelque-soit l'endroit
● Raisons:

– Architecture technique très riche
– Composants riches => Ne pas réinventer la roue
– “Bon Fwk”: Rend simple les choses à faire

... difficile les choses à ne pas faire



Eclipse Workbench Windows

● 1 Application -> 1..* Main Window(s) + 0..* Views
– Menu Principal 
– Toolbars
– Working Area
– StatusBar

● Plusieurs fenêtres avec menu :

● Docking views
(fenêtres sans menu)



Eclipse Workbench : Perspectives

● 1 Perspective : correspond à 1 type d'activité
● Exemple: 

– Browsing, editing, debugging...
● Graphiquement : “1 fenêtre dans la fenêtre”

... mais influence Menu, Toolbar, Shortcut...
● Switch entre perspectives:



Perspective Toolbar Icons

● Astuce pour gain d'espace : no “Show Text”

● Autre config: “Dock On > Left”



Open New Perspective

● Cf menu Window > Open Perspective > ...



Eclipse Views & Editors

● Contenus de la “working area” des fenêtres
● Dockables (config par drag & drop)
● Views toujours aux bords
● Editors toujours au centre

Editors

Views

Editors Editors



Docking + Onglets / Editors Multi-Type

● Views et Editors sont superposables en onglets

●  != onglets (en bas) pour Editors multi-modes
– Ex: fichier XML => mode text, mode structure



Différences Views - Editors

● Editors = modification en mémoire (buffer)
   nom fichier avec “*” => necessite “Ctrl+S”

● Views = modification immédiate
– contient Toolbar
– préf. configurables, ex: Filter, Sort, Group ...

● En général:
– Editors pour manipulation de fichiers
– Views pour Read-only , Navigation, properties...



Editors

● Open Editor
– Double-click => editor par défaut
– Right-click => Open with
– Reuse editor:

1 max par editor-type

● Editors = associés par type de fichiers
– Cf menu 

Window > Preferences...



Views

● Open View: menu Window > Show View ...



Workspace – Project - Resource

● Niveau 0: Workspace
 = Session de travail (répertoire racine)
– Contient liste de Projets

● Niveau 1: Projects
– Module de compilation
– Contient des resources

● Niveau 2-*: Resources
– Fichiers / Répertoires enrichis par eclipse
– Sources ou générés, autres...



Workspace

● 1 process eclipse => 1 workspace
= session en mémoire = répertoire

● Le Workspace contient
– .metadata

● Données globales de configuration
cf menu “Window > Preferences ...”

● Caches, indexes ...=> répertoire volumineux!
● Fichiers d'administration (.lock, logs ...)

– Répertoires de Projets (déconseillé)



Start Eclipse - Workspace

● Au démarrage
– Par défaut: ~/workspace
– Au choix par dialog box
– Ou par option “-data <dir>”

● Recommandations
– “-showlocation -data ... ”
– Utiliser N scripts start.sh, 1 par env

● Remarques: Après un kill => supprimer fichier 
“<workspace> / .metadata / .lock”



Customisation Workspace Preferences

● Exemple de Preferences globales à configurer
– General > Run in background
– Compare > Ignore whitespace
– Java > classpath var MAVEN_REPO
– Java > Compiler > no clobber on clean
– Team > use pure java svnkit
– URL proxy http
– Schema xml
– ...



... Projects

● Niveau 0: Workspace / 1: Projects / 2: Resources



Eclipse Projects

● Project = module de travail (compilation, run..)
● Contenu

– Fichiers “.project”, “.classpath”
– Répertoire(s) source

● Std : src/main/java et src/test/java
– Répertoire(s) build

● Std : target/classes et target/test-classes
– Project dependencies (project / .jar)
– Project “.settings”



Project Natures / Builders

● Projet (nature) “Java”

● Un projet peut avoir plusieurs natures / builders 
Ex: C, C++, Ejb, Xdoclet, Uml, ...



New Project ...

● New > Project ... > Java Project



New Project ... (2)



New Project ... NO Default Location (3)

● Conseil : externaliser projets 
– Changer le répertoire par défaut !!!
– On ne gère JAMAIS le workspace dans SVN

(répertoire custom, trop volumineux...)



New Project ... Properties (4) 

● Properties configurables 
même après création
... Cf ctx menu



Import Existing Project

● Ctx menu “Import > Existing Project... ”
=> “lien” vers répertoire externe
=> les données ne sont pas copiées

● “Import” plutôt que “new” :
– Soit importé depuis SVN  ... cf cours SVN
– Soit généré par maven ... cf next / cours maven



Delete / Close Project

● Delete Project => supprime le “lien” seulement
... ne pas selectionner “delete content” !

● Close / Open Project
=> garder dans wsp, pas en mémoire



Projet Eclipse / Projet Référence Maven

● Créer un projet manuellement = pénible
● Référence de compilation != Eclipse

– Cf Intégration Continue
(lancement automatique des builds: maven...)

● Choix perso développeurs
– Customizer ses projets
– Utiliser un autre outil (?)

● La gestion des dépendances est laborieuse
● ==> cf Maven !!!



New Project Maven + Generate Eclipse
● Pour créer un projet en 1 minute !!
● $ mvn archetype:generate

      -DgroupId=<pckg> -DartifactId=<proj>
==> pom.xml + répertoires créés

● $ mvn eclipse:eclipse
==> .project, .classpath

● eclipse “> import...”



Maven Pom.xml 

● Syntaxe lisible... doc: www.maven.org
● Approche declarative (conf  != impérative / code)

http://www.maven.org/


Sources Build Path

● Standard: src/main/java, src/test/java



Project to Project Dependencies

● Les Projets peuvent être dépendants entre eux
– Pas cycliquement!
– Eclipse respecte l'ordre de compilation
– Compilation incrémentale sans jars

● Ex typique: modules client/server/shared/fwk...



Project Jar Dependencies

● Standard: use classpath variable (cf maven)
● Façon déconseillée: \lib\*.jar !! ou abs. filename !



Maven2 = Gérer les Dépendances

● Il n'est pas rare d'importer 20-30 jars...
– Ex: Log4j + Commons-Lang + Commons-Utils + 

Spring + Hibernate + Jdbc-Oracle + ... 
● Maven simplifie les dépendances !
● Avec 3 lignes config ==> 

– Download automatique des jars + versions
– Dépendances transitives
– Repository de jars

(gain d'espace disque + perf IOs + Svn)
– Pas de scripts ant / de classpath complexes



Manually adding Eclipse Dependency

● Project > Properties ... > Libraries > Add 
Variable... > Extend ... 



Eclipse - MAVEN_REPO

● A configurer 1 seule fois dans Préférences



Adding Library from Maven+Eclipse

1) Editer le fichier “pom.xml”
exemple: ajouter log4j:

2) compile (=> download jar) 
$ mvn jar:install

3) Re-générer fichiers d'eclipse:
$ mvn eclipse:eclipse

4) sous Eclipse : refresh project “.classpath”



Adding Maven Dependencies

● Historiquement, utilisation de repository 
“statiques”, de référence
       http://www.ibiblio.org/maven
     

● Utilisation des moteurs de recherches google...
● … Mieux: moteurs de recherche + repository 

dédiés à maven ! 
Exemple : Nexus hosted by Sonatype

 http://repository.sonatype.org/index.html



Nexus Repository
ex: http://repository.sonatype.org



1000 avantages Maven

● Maven est un outil INCONTOURNABLE
● Surcouche de “ant”
● Intègre de nombreux outils

– Ex: junit, xdoclet, cobertura, findbugs...
– presque SANS code : plugins prèt à l'emploi
– Config “déclarative” de projets : pom.xml

● Lancement “$ mvn jar:install” <plugin>:<goal>
– En intégration continue: CruiseControl ...

● Cf. doc maven...



Conclusion

● Questions Eclipse ?
● Questions Maven ?
● A voir aussi …

– Integration Continue
– Junit, Cobertura, Ioc, Spring
– Hudson
– Sonar
– Jira
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